eeprom+

UART/M-BUS/BDM адаптер

171 сообщение в этой теме

Из прогера 30 29 ножки  пойдет 10в 12в 

Через  Powertest провел 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тогда в твоем адаптере что-то коротит. Может в место стабилитрона диод поставил. 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тоже на прошлой неделе собрал адаптер.

При первом подключении адаптера к компьютеру и выполнении теста выдает ошибку:

**** VCC = 3V ****
  Voltage = 0.0V                 Error.
  BDM out = 1, BDM in = 1        OK
  RESET out = 1, Reset in = 1    OK
  BDM out = 0,   BDM in = 0.     OK
  RESET out = 0,   RESET in = 0. OK
    TX ---|<|---- BDM
  TX = 1, BDM in = 1.            OK
  TX = 0, BDM in = 0.            OK
    BDM_RESET ---|<|---- RX
  RESET = 1, RX in = 1.          OK
  RESET = 0, RX in = 0.          OK
    P0 ---|<|---- BDM
  P0 = 1, BDM in = 1.            OK
  P0 = 0, BDM in = 0.            OK
    P1 ---|<|---- BDM
  P1 = 1, BDM in = 1.            OK
  P1 = 0, BDM in = 0.            OK
MBUS test
MBUS disabled.
  TX = 0, RX = 1.                OK
  MBUS --|<|-- BDM               OK
MBUS enabled.
  TX = 0, RX = 0.                OK
**** VCC = 5V ****
  Voltage = 4.9V                 OK
  BDM out = 1, BDM in = 1        OK
  RESET out = 1, Reset in = 1    OK
  BDM out = 0,   BDM in = 0.     OK
  RESET out = 0,   RESET in = 0. OK
    TX ---|<|---- BDM
  TX = 1, BDM in = 1.            OK
  TX = 0, BDM in = 0.            OK
    BDM_RESET ---|<|---- RX
  RESET = 1, RX in = 1.          OK
  RESET = 0, RX in = 0.          OK
    P0 ---|<|---- BDM
  P0 = 1, BDM in = 1.            OK
  P0 = 0, BDM in = 0.            OK
    P1 ---|<|---- BDM
  P1 = 1, BDM in = 1.            OK
  P1 = 0, BDM in = 0.            OK
MBUS test
MBUS disabled.
  TX = 0, RX = 1.                OK
  MBUS --|<|-- BDM               OK
MBUS enabled.
  TX = 0, RX = 0.                OK
  10V = 10.2V                    OK
  7.5V = 7.6V                    OK
 
 Тест завершен. Ошибок: 1

Если повторно нажать тест, то ошибок нет.

Каждое новое переподключение программатора к компьютеру выдает эту ошибку по 3.3В

Подскажите пожалуйста.

 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это нормально. Так и должно быть. 

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Audis почему надо 10в

Если 10в нету адаптер не работает да

Denso скрипты работает или не работает скажите пожалуйста 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

7,5/10в это управляющее напрежение с которым возможно чтото комутировать с 6 выводом (8 выводный разем).

Для остальной работы адаптера это напряжение не имеет отношения.

Про денсо не отвечу, он нужен или нет. У меня нет этих скриптов.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

7.5 10в какой из ножки приходит

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
11 минуту назад, audis сказал:

7,5/10в это управляющее напрежение с которым возможно чтото комутировать с 6 выводо (8 выводный разем).

Для остальной работы адаптера это напряжение не имеет отношения.

Про денсо не отвечу, он нужен или нет. У меня нет этих скриптов.

 

Что вы думаете о том, что может быть 

проверка, куда идти за 7,5 10V
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

трудно вам тут чтото подсказать когда не видишь платы. покажите фото может чтото будет возможно подсказать.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

10V = 0.0V Error
7.5V = 0.0V Error

- получается что вообще в адаптере на массе 29 и 30 ноги DB44

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Собрал адаптер, на тесте выдает ошибки по питанию 3в и 5в, а мультиметром проверяю они есть

Где-то накосячил?

**** VCC = 3V ****
  Voltage = 0.0V                 Error.
  BDM out = 1, BDM in = 1        OK
  RESET out = 1, Reset in = 1    OK
  BDM out = 0,   BDM in = 0.     OK
  RESET out = 0,   RESET in = 0. OK
    TX ---|<|---- BDM
  TX = 1, BDM in = 1.            OK
  TX = 0, BDM in = 0.            OK
    BDM_RESET ---|<|---- RX
  RESET = 1, RX in = 1.          OK
  RESET = 0, RX in = 0.          OK
    P0 ---|<|---- BDM
  P0 = 1, BDM in = 1.            OK
  P0 = 0, BDM in = 0.            OK
    P1 ---|<|---- BDM
  P1 = 1, BDM in = 1.            OK
  P1 = 0, BDM in = 0.            OK
MBUS test
MBUS disabled.
  TX = 0, RX = 1.                OK
  MBUS --|<|-- BDM               OK
MBUS enabled.
  TX = 0, RX = 0.                OK
**** VCC = 5V ****
  Voltage = 0.0V                 Error.
  BDM out = 1, BDM in = 1        OK
  RESET out = 1, Reset in = 1    OK
  BDM out = 0,   BDM in = 0.     OK
  RESET out = 0,   RESET in = 0. OK
    TX ---|<|---- BDM
  TX = 1, BDM in = 1.            OK
  TX = 0, BDM in = 0.            OK
    BDM_RESET ---|<|---- RX
  RESET = 1, RX in = 1.          OK
  RESET = 0, RX in = 0.          OK
    P0 ---|<|---- BDM
  P0 = 1, BDM in = 1.            OK
  P0 = 0, BDM in = 0.            OK
    P1 ---|<|---- BDM
  P1 = 1, BDM in = 1.            OK
  P1 = 0, BDM in = 0.            OK
MBUS test
MBUS disabled.
  TX = 0, RX = 1.                OK
  MBUS --|<|-- BDM               OK
MBUS enabled.
  TX = 0, RX = 0.                OK
  10V = 10.2V                    OK
  7.5V = 7.6V                    OK
 
 Тест завершен. Ошибок: 2

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Проверьте правильно ли собрали заглушку для теста. 

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Заглушку собрал правильно, а тест 3 и 5В не проходят

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Соединяются ли 32 и 42 ноги разъема в адаптере?

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
9 часов назад, eeprom+ сказал:

Соединяются ли 32 и 42 ноги разъема в адаптере?

Спасибо! 42 нога не пропаяна была.

Выкладываю печатку в lay формате, рисовал для себя, но надеюсь еще кому пригодится

mbus.lay6

Изменено пользователем lykov
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет !!! 

Подскажите, можно ли по минимуму бдм собрать без микросхем.  Купил скрипт на Весту завтра Веста приезжает а адаптера нет :(

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

конечно можно. мне схемку дал автор скрипта по вестам, ровно минуту на сборку ,в личку схему кинул

Изменено пользователем Владимир1969
2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так может сюда схему выложить?

2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

так я то не против

BDM0.JPG

5

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Рспект автору скрипта

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

схемку собрал на Весте проверил.  Работает!!!

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу